Лабораторная работа по дисциплине «Компьютерная схемотехника» Система проектирования мax+plus II icon

Лабораторная работа по дисциплине «Компьютерная схемотехника» Система проектирования мax+plus II

Смотрите также:
Лабораторная работа №2 по дисциплине...
Лабораторная работа №7 по дисциплине...
Лабораторная работа №8 по дисциплине...
Лабораторная работа №1 по дисциплине...
Лабораторная работа по дисциплине компьютерная графика. На тему: Видео технологии...
Методические указания к выполнению лабораторной работы №9 «Компьютерная система регулирования...
Отчет по дисциплине «Учебная практика по информатике»...
Изучение макрокоманд программы ms excel с выполнением контр...
Лабораторная работа №1...
Лабораторная работа №7...
Тип инфузории
Методические указания к лабораторным работам со стендом...



скачать


Лабораторная работа

по дисциплине «Компьютерная схемотехника»


Система проектирования МAX+plus II

(Выполняйте на своих компьютерах все действия, набранные жирным курсивом)


Основные понятия

Современная элементная база предполагает использование новых технологий проектирования и современных средств проектирования.

Проектирование цифровых устройств на базе микросхем программируемой логики в настоящее время во всем мире осуществляется при помощи системы автоматизированного проектирования (САПР). Наиболее часто используются САПР corp. ALTERA:

  • MAX+plus II — САПР, поддерживающий работу с относительно простыми семействами СБИС ПЛ;

  • Quartus II — САПР, поддерживающий работу со всеми новыми семействами СБИС ПЛ, обеспечивающий доступ ко всем развитым ресурсам микросхем, позволяющий вести проектирование программно-аппаратных систем.

Для ознакомления с возможностями современных средств проектирования выберем САПР MAX+plus II.

Этот выбор обусловлен тем, что система MAX+plus II позволяет осуществлять графический ввод проекта. При зтом проектирование становится возможным без овладения специальными языками описания аппаратуры: AHDL, VHDL, Verilog HDL и представляет собой довольно занимательный и увлекательный процесс. С увеличением сложности проектов, выполнение их графического ввода становится все боле и более трудоемкой задачей. С помощью специального языка описания аппаратуры проще и быстрее ввести и проверить большой проект.

Название системы МAX+plus II является аббревиатурой от Multiple Array мatriХ Programmable Logic User System (Пользовательская система программирования логики упорядоченных структур). Система МAX+plus II разработана фирмой Altera и обеспечивает создание проектов, которые легко приспосабливаются к конкретным требованиям пользователя. Система МAX+plus II имеет средства удобного ведения проекта, быстрого анализа, как логики, так и часовых параметров, непосредственного программирования устройств.

Имеется возможность описания проекта в виде файла на языке описания аппаратуры, созданному во внешнем редакторе или в текстовом редакторе MAX+plus2, в виде электрической схемы, созданной в графическом редакторе Graphiс Editor, в виде часовой диаграммы, созданной в редакторе Waveform Editor. Для работы со сложными иерархическими проектами из каждой части схемы может быть создан символ, редактирование которого выполняется в графическом редакторе. Под проектом понимается совокупность иерархически связанных файлов проекта. Такие команды, как открытие файлов, ввод назначений устройств, выводов и логических элементов, компиляция проекта – похожие для многих редакторов. Разные редакторы при разработке проекта позволяют выполнять похожие задачи (например поиск символа) похожими средствами. Можно легко комбинировать разные типы файлов проекта в иерархическом проекте, избирая для каждого функционального блока тот формат, который больше всего подходит.

Процедурой разработки нового проекта выглядит следующим образом:

- создание нового файла проекта или иерархической структуры нескольких файлов проекта с использованием редакторов разработки проекта в системе MAX+plus II;

- задание имени файла проекта в качестве имени проекта;

- назначение семейства ПЛИС для реализации проекта (пользователь может сам назначить конкретное устройство или предложить это компилятору для оценки ресурсов);

- открытие окна компилятора (Compiler) и его запуск нажатием кнопки Start для начала компиляции проекта;

- в случае удачной компиляции проекта имеется возможность выполнения его тестирования и часового анализа, для проведения которого необходимо: а) открыть окно Timing Analyzer, выбрать режим анализа и нажать кнопку Start; б) для начала тестирования нужно создать тестовый вектор в формате канала тестирования (.scf), пользуясь сигнальным редактором, или в формате вектора (.vec) пользуясь текстовым редактором, а затем открыть окно Симулятора и нажать кнопку Start;

- программирование выполняется путем запуска модуля программатора (Programmer) с последующим расположением устройства ПЛИС в программирующий адаптер программатора.


^ Ввод проекта в системе МAX+plus II

После запуска системы Мах+plus II автоматически открывается ее главное меню, которое охватывает все прикладные программы этой системы. В верхней части окна отображается имя проекта и текущего файла проекта. Потом отображенная строчка меню, а под ней панель основных инструментов системы, которая обеспечивает быстрый вызов ее компонентов. Вызов компонентов системы удобно проводить через окно меню МAX+plus II, представленного на рис.1. В табл.1. приведены функции которые отвечают пунктам меню Мах+plus2, а также описывается их назначение.




Рис. 1 - Меню МAX+plus II


Таблица 1- Панель команд системы МAX+plus II

Команда



Функция


1

2

^ Hierarchy Display



Обзор иерархии – отображает текущую иерархическую структуру файлов в виде дерева с ветвями, что представляют собой отдельные файлы проекта. Можно визуально определить, является ли файл проекта схемным, текстовым или сигнальным, какие файлы открыты в данный момент, какие вспомогательные файлы в проекте доступные пользователю для редактирования

^ Graphic Editor


Графический редактор – позволяет разрабатывать схемный логический дизайн в формате реального отображения на экране монитора, применяя разработанные фирмой Altera и собственные: примитивы, мегафункции и макрофункции как основные блоки разработки.

^ Symbol Editor


Символьный редактор – позволяет редактировать существующие символы и создавать новые.


^ Text Editor


Текстовый редактор – позволяет создавать и редактировать текстовые файлы проекта, написанные на языках описания аппаратуры AHDL, VHDL и Verilog HDL. Кроме того, в этом редакторе можно создавать, пересматривать и редактировать другие файлы формата ASCII, которые используются другими редакторами системы МAX+plus II. Можно создавать файлы на языках HDL и в других текстовых редакторах, однако текстовый редактор системы МAX+plus II дает преимущества в виде контекстной справки, выделят цветом синтаксические конструкцие и готовые шаблоны языков AHDL, VHDL и Verilog HDL.

^ Waveform Editor


Сигнальный редактор – выполняет двойную функцию: инструмент для разработки дизайна и инструмент для введения тестовых сигналов и наблюдения результатов тестирования.

Продолжение таблицы 1

1

2

^ Floorplan Editor


Поуровневый планировщик – позволяет графическими средствами редактировать расположение выводов на чертеже корпуса устройства и назначать сигналы отдельным логическим элементам на более подробной схеме логической структуры (LAB view). Позволяет просматривать результаты последней компиляции.

Compiler


Компилятор – обрабатывает логические проекты, разработанные для семейств устройств Altera Classic, MAX 5000, MAX 7000, MAX 9000, FLEX 6000, FLEX 8000 и FLEX 10K. Большинство заданий выполняется автоматически. Однако пользователь может руководить процессом компиляции полностью или частично.

^ Program- mer


Программатор – позволяет программировать, конфигурировать, проводить верификацию и испытать устройства фирмы Altera.



Simulator


Симулятор – позволяет тестировать логические операции и внутреннюю синхронизацию спроектированной логической схемы. Возможны три режима тестирования: функциональное, часовое и тестирование нескольких соединенных между собой устройств.


^ Timing Analyzer


Анализатор часовых параметров – анализирует работу проектируемой логической схемы после того, как она была синтезирована и оптимизирована компилятором. Позволяет оценить задержки, что возникают в схеме.


^ Message Processor


Генератор сообщений – выдает на экран сообщения об ошибках, что позволяет пользователю автоматически найти источник сообщения в исходном или вспомогательном файле (файлах) проекта и в поуровневом планировщике.



Программное обеспечение системы содержит одиннадцать прикладных программ и главную управляющую оболочку. Разные дополнительные программы, что создают файлы проекта, могут быть активизированы мгновенно путем выбора соответствующего пункта меню и нажатием левой кнопки мыши.

^ Файл проекта – это графический, текстовый или сигнальный файл, созданный посредством соответствующего редактору системы МAX+plus II. Проект состоит из всех файлов иерархической структуры дизайна. Поэтому каждый новый проект желательно начинать в новом подкаталоге с соответствующим названием. Схемные файлы проекта создаются в графическом редакторе. Можно также открыть, отредактировать и сохранить схемы, созданные схемным редактором OrCAD.

^ Вспомогательные файлы - это файлы, что связаны с проектом МAX+plus II, но не являются частью иерархического дерева проекта. Большинство таких файлов не содержит логики дизайна. Некоторые из них создаются автоматически добавлением системы МAX+plus II, другие - пользователем. Примерами вспомогательных файлов являются файлы назначений и конфигурации (.acf), символьные файлы (.sym), файлы отчета (.rpt) и файлы тестовых векторов (.vec). Проект состоит из всех файлов иерархической структуры дизайна, в том числе вспомогательных и исходных файлов. Именем проекта является имя файла верхнего уровня без расширения.


^ Работа в графическом редакторе


При выборе пункта New появляется окно (рис.2), в котором предлагается выбрать редактор, где будет создан главный файл проекта. При выборе одного из пунктов и нажатии кнопки ОК запускается соответствующий редактор. Следует выбрать Graphic Editor File. Другие пункты меню File имеют тоже назначение, что и во многих программах Windows. Это открытие уже существующего файла проекта (Open), сохранение создаваемого (Save, Save as), информация о файле (Info), его размере (Size), а также выход из системы МAX+plus II (Exit МAX+plus II).

В меню Edit содержатся команды копирования (Copy), вырезания (Cut), вставки (Paste), уничтожение (Delete) элементов схемы, отмены последнего действия (Undo). Кроме того команды Flip Vertical, Flip Horizontal, Rotate, позволят вращать элементы схемы, что упрощает построение логической схемы. В меню View содержатся команды по управлению отображением схемы: на весь экран, увеличение масштаба, уменьшения масштаба, нормальный размер и максимальный.





Рис. 2 - Диалоговое окно New


В меню Symbol (рис.3) содержатся следующие команды:

- Enter Symbol - открывает окно выбора элемента, который нужно добавить в схему (см. рис.4);

- Edit Ports/Parameters - открывает окно назначения выводов элементов в схеме соответствующим выводам на корпусе микросхеме;

- Update Symbol - обновляет символ в схеме.




^

Рис. 3 - Команды меню Symbol







Рис. 4 - Диалоговое окно Enter Symbol


После ввода в схему проекта элементов следует выполнить их компоновку и необходимые соединения. Для этого нужно пользоваться инструментами из основной панели инструментов, вид которой показан на рис.5.





- Выделяет элементы схемы, линии, узлы, текст.

- Позволяет вставить текст в любом городе схемы.

- Чертит линии под прямым углом

- Чертит прямую линию

- Чертит дугу

- Чертит круг

- Увеличивает масштаб схемы

- Уменьшает масштаб схемы

- Изменяет масштаб, чтобы схема вместилась на весь экран. Рис. 5 - Основная

- Ставит узел в схеме. панель инструментов


- Включает привязку линий к элементам схемы.

- Выключает привязку линий к элементам схемы


Пользуясь информацией из рисунков 2-5 вы можете создать в графическом редакторе схемный файл своего проекта. Проекты в системе МAX+plus II принято сохранять в директории max2work.

С целью экономии времени, введите в графический редактор из директории max2work проект Ctr. Этот проект представляет собой пример проектирования ICTR20 из вашего учебного пособия по проектированию микропроцессорных устройств на ПЛИС ( см. стр. 118 – 123 пособия).


^ Компиляция проекта


Посредством команд с меню Assign имеется возможность вводить, редактировать и уничтожать типы назначений ресурсов, приборов и параметров, которые управляют компиляцией проекта. Вид меню приведен на рис. 6.


Рис. 6 - Меню Assign


Команда Device – выбор устройства. Назначает тип ПЛИС, в которой будет реализованный проект. Если проект состоит из нескольких устройств, данная функция назначает ИС конкретным проектам. Можно также избирать опцию AUTO. Тогда компилятор сам выберет устройство из данного семейства. Вообще, перед разработкой схемы следует избрать тип ИС, посредством которой будет реализована поставленная задача.

Pin/Location/Chip – назначает вход или выход логической функции конкретному контакту из вертикального или горизонтального ряда.

В поле Node Name вводится название контакта. Название должно отвечать названию одного из контактов на схеме. Названия не должны совпадать. В противном случае компилятор выдаст ошибку. В поле Chip name вводится название чипа. Часто название чипа совпадает с названием главного файла проекта. В поле Pin следует ввести номер вывода на микросхеме. Нельзя двум выводам в схеме назначать одинаковые выводы на микросхеме. В поле Pin Type вводится назначение вывода: вход (input), выход (output), двунаправленный (bidir) или неопределенный. Внимательно следите по назначению типа вывода. Нельзя назначать выводам, на которые подается входной сигнал, тип output - может выйти из строя ИС.

В поле Existing Pin/Lokation/Chip Assigments можно увидеть выводы схемы, которым уже назначенные выводы на ИC. В полях Row и Column указывается в какой строке или колонке соответственно должны быть выводы на ИC. Если не указанные параметры, то компилятор сам назначит выводам ИC соответствующие выводы схемы из расчета наименьшей ресурсоемкости и максимально возможного быстродействия (минимальных часовых задержек) ИС.

Когда схема завершена и выводам на схеме назначенные выводы на устройстве, можно компилировать проект. Для этого с меню File-> Project следует выбрать команду Save&Compile. Можно проверить схему на ошибки. Для этого избирается команда Save&Check, или нажимается соответствующая кнопка на панели инструментов. При удачной компиляции появится сообщение (рис.7).





Рис. 7 – Сообщение об удачной компиляции проекта


Если напротив errors не будет стоять 0, то это означает, что в схеме имеются ошибки, которые для успешной компиляции проекта следует исправить. Выявить ошибки поможет Message Processor, окно которого можно открыть выбором этой команды с меню МAX+plus II. Окно компилятора изображено на рис.8.




Рис. 8 - Окно компилятора


Прямоугольники сверху указывают, какое именно действие выполняется в текущий момент. Под ними указанные расширения файлов, которые создаются в каталоге проекта. Индикатор внизу окна показывает объем выполненной компилятором работы. Остановить компиляцию в любой момент времени можно нажатием кнопки Stop.

В соответствии с вышеописанным, выполните компиляцию проекта Ctr.

После выполнения компиляции проекта откройте окно Floorplan Editor, нажав соответствующую кнопку на панели инструментов (табл.1) или выбрав соответствующую команду с меню МAX+plus II (рис.1).

Для переключения вида ИС следует дважды нажать левую кнопку мыши на ней. Черным цветом отражаются ножки, использовать которые пользователю не позволяется. Они предназначены для питания ИС, а также для ее программирования. Слева размещены инструменты изменения масштаба. Они работают аналогично инструментам других редакторов системы МAX+plus II. Белым цветом обозначены выводы, которые не имеют назначений. Красным – выводы, для которых не удалось выполнить назначения. В поле Chip Name выбирается тип микросхемы. Это действие выполняется при необходимости разбития проекта на части. Во время компиляции создается файл, в котором содержится информация о компиляции. Это текстовый файл, который имеет расширение .rpt. Чтоб его открыть, нужно в меню File выбрать команду Open.


^ Анализ временных задержек


Проанализировать часовые задержки можно посредством сигнального редактора, симулятора и часового анализатора, окна которых можно открыть, выбрав с меню МAX+plus II (рис.1) соответствующий пункт. Сначала рассмотрим работу в сигнальном редакторе.

В Сигнальном редакторе (Waveform Editor) задаются и исследуются часовые соотношения. Сигнальный редактор выполняет две роли: он является инструментом ввода логики посредством часовых диаграмм и анализа результатов тестирования. Пользователь может создавать сигнальные файлы проекта (.wdf), которые содержат логику для проекта, а также файлы каналов тестирования (.scf), которые содержат входные векторы для тестирования и функциональной наладки. Новый файл можно создать командой New меню File, но сначала нужно открыть сигнальный редактор (Waveform Editor). Для этого с меню МAX+plus II нужно выбрать пункт Waveform Editor (рис.1).

Сигнальный редактор имеет следующие возможности:

- можно создать или отредактировать узел схемы, который имеет входной или выходной контакт;

- можно копировать, вставлять, перемещать и уничтожать выбранную часть формы сигнала или всю форму;

- имеется возможность отображать на экране сетку, вводить комментарии, изменять масштаб отображения.

Запустивши систему МAX+plus II и открыв сигнальный редактор, нужно записать проектируемый файл на диск. Для этого в диалоговом окне сохранения файла (File->Save As) следует установить расширение .wdf.

Для ввода названия вывода схемы дважды нажимаем левую кнопку мыши, предварительно установив курсор в поле Name или в меню Node выбираем команду Insert Node. Появится окно, показанное на рис.9.





Рис. 9 - Диалоговое окно Insert Node


В поле Node Name следует ввести название вывода, а в I/O Type указать его тип. После этого нажать кнопку ОK. В поле Default Value указывается начальное значение сигнала на этом выводе. Подобную проце-дуру следует провести для всех входных и выходных выводов анализируемого узла логической схемы.

Теперь нужно нари-совать часовые диаграммы. Для этого в сигнальном редакторе, нужно сделать следующее: нажимаем левую кнопку мыши напротив вывода ’in’ и между значениями времени 100ns и 200ns (удерживая ее) переместим курсор направо. Появится черный прямоугольник, что свидетельствует о выделении этого промежутка. Для выделения большего промежутка времени следует нажать левую кнопку мыши, и не отпуская ее протянуть курсор по необходимой зоне.

Слева экрана активизируется панель инструментов, на которой расположены следующие кнопки: увеличение масштаба изображения часовой диаграммы; уменьшение масштаба изображения часовой диаграммы; изменение масштаба; установление уровня логического нуля; установление уровня логической единицы; неопределенное значение; уровень высокого импеданса; инверсия сигнала; последовательность импульсов 0-1-0-1-0-1-0-1-0-1-0-1-.; задает свободную последовательность импульсов ( например 0-1-1-0-1-1-0-1-1-0-1-.).

Когда область имеет выделение нужно нажать на кнопку «Установка уровня логической единицы». Такую же самую процедуру нужно повторить для всех других выводов ’in ’ и ’out’, выделив соответствующую область. Можно назначить выводам на схеме соответствующие выводы непосредственно на ИС. Для этого в меню Assign нужно выбрать команду Pin/Location/Chip.

Также необходимо задать часовой диапазон. Для этого в меню File  следует выбрать команду End Time. Появится окно, показанное на рис.10.


Рис. 10 - Диалоговое окно End Time

^ В поле End Time следует указать граничный интервал времени, на протяжении которого вам удалось описать работу схемы часовыми диаграммами в сигнальном редакторе.

В меню View имеется команда Time Range. Она позволяет задавать промежуток времени, который будет отображаться на экране монитора. Если все это сделано, можно компилировать проект. Для этого следует одновременно нажать кнопки Ctrl и L. В случае удачной компиляции проекта появится стандартное сообщение.

Таким образом, выполнив вышеописанную процедуру работы с сигнальным редактором, мы сможем получить результат компиляции подобный результату, полученному при использовании графического редактора.

Для верификации проекта (рис.11) используются три приложения: симулятор (Simulator), анализатор временных параметров (Timing Analyzer) и сигнальний редактор (Waveform Editor).

Откомпилировав схему, спроектированную в графическом редакторе, откроем окно симулятора, выбрав команду Simulator из главного меню системы.

Окно симулятора показано на рис.12. Устанавливаем отметки Setup/Hold и Oscillation. В поле Oscillation вводим значение, которое ранее было установлено в поле End Time. После нажатия кнопки Start, симулятор проанализирует логику схемы. По завершении анализа, нажав на кнопку «Open SCF», на экране монитора увидим полученные часовые диаграммы работы схемы.





Рис. 11 - Верификация проекта в системе MAX+plus II


На этой диаграмме легко увидеть часовые задержки, что возникают в схеме. Установив ползунок синего цвета на фронте или спаде сигнала путем перемещения серого квадрату при нажатой левой кнопке мыши, а курсор на фронте или спаде исходного сигнала, в поле Interval увидим значение задержки.

Симулятор MAX+PLUS II - это мощный инструмент для анализа временных задержек проекта и проверки его на предмет соответствия выполняемой им логической функции.

Симулятор позволяет проверить ваш проект перед его реализацией в кремнии. С помощью симулятора возможно осуществлять анализ временных задержек с разрешающей способностью вплоть до 0.1 ns.




^

Рис. 12 - Диалоговое окно симулятора



Посредством редактора Timing Analyzer очень легко увидеть все часовые параметры схемы. Редактор Timing Analyzer вызывается путем выбора соответствующей команды из главного меню системы. После нажатия кнопки «Start» в окне Timing Analyzer, на экране монитора увидим таблицу, содержащую часовые параметры схемы.

Проанализируйте полученные часовые параметры схемы и определите максимально-возможную частоту синхронизации CLOCK fmax , при которой схема остается работоспособной.

Как видно из таблицы часовых параметров, наибольшая задержка в схеме имеет место на

D – входе триггера Q19 по отношению ко входу F1. Она составляет 40,5 нс. Переключение триггера Q19 осуществляется по переднему фронту синхросигнала CLOCK. При этом информация на выходе триггера, как видно из анализируемой таблицы, по отношению к его D – входу появляется через 14,7 нс. Однако задержки переключения триггеров не являются критичными для работы анализируемой схемы, так как они осуществляются параллельно с формированием сигналов X1 и X2 в схеме. В связи с этим fmax =1/40,5 нс = 24,69MHz.

Для проверки правильности проведенного анализа, при открытом окне Timing Analyzer, в меню Analysis выберите опцию Registered Performance и в появившемся окне нажмите кнопку «Start».


Выполните вышеописанные действия для проекта по вашему варианту. Убедитесь в его работоспособности и определите максимально-возможную частоту синхронизации CLOCK fmax для вашего проекта.


База данных защищена авторским правом © kursovaya-referat.ru 2017
При копировании материала укажите ссылку